Announcement

Collapse
No announcement yet.

Issue with K-Dcan cable and Windows 10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue with K-Dcan cable and Windows 10

    I had INPA and my cable working for awhile then stopped working after an update.

    The cable is no longer recognized, can’t find the driver…I think. The cable is modified with the 2 pins bridged.

    Anyone encounter something similar and fix it without using a virtual machine?


    Sent from my iPhone using Tapatalk

    #2
    Originally posted by bigjae46 View Post
    I had INPA and my cable working for awhile then stopped working after an update.

    The cable is no longer recognized, can’t find the driver…I think. The cable is modified with the 2 pins bridged.

    Anyone encounter something similar and fix it without using a virtual machine?


    Sent from my iPhone using Tapatalk
    Does it show in the device manager when you plug it in? You can undo updates and revert the driver to the previous version. If this is a second computer only for BMW software, it might be good to disable updates.

    Comment


      #3
      Side question, what's the best cable to get for laptop hookup?
      2003.5 MT JB/B - CSL SCHRICK SUPERSPRINT EISENMANN JRZ SWIFT MILLWAY BREMBO ENDLESS BBS/SSR DREXLER SACHS RECARO SLON MKRS GSP DMG KARBONIUS CP AUTOSOLUTIONS KOYO

      Comment


        #4
        Originally posted by Slideways View Post

        Does it show in the device manager when you plug it in? You can undo updates and revert the driver to the previous version. If this is a second computer only for BMW software, it might be good to disable updates.
        No, just says unknown device.


        Sent from my iPhone using Tapatalk

        Comment


          #5
          Originally posted by bigjae46 View Post

          No, just says unknown device.


          Sent from my iPhone using Tapatalk
          Can you try the cable on another USB port or try another laptop with windows 7 or an earlier version of 10?

          This thread has some information on the driver and someone with a similar issue - https://www.e90post.com/forums/showthread.php?t=871005

          Comment


            #6
            Originally posted by Slideways View Post

            Can you try the cable on another USB port or try another laptop with windows 7 or an earlier version of 10?

            This thread has some information on the driver and someone with a similar issue - https://www.e90post.com/forums/showthread.php?t=871005
            Thanks! Never occurred to me that my cheap chinese OBDII reader could be broken. Who would have thought that?..lol

            Comment


              #7
              Originally posted by jet_dogg View Post
              Side question, what's the best cable to get for laptop hookup?
              my experience, any cable has worked, regardless if brand or no-name. i went with one i saw on amazon that i liked only because i liked the button vs the switch. only requirement is getting the cable that supports pre- and post-07 vehicles should you run into that. this is the one i got.
              https://www.amazon.com/gp/product/B095LW5CKW/

              Originally posted by bigjae46 View Post

              Thanks! Never occurred to me that my cheap chinese OBDII reader could be broken. Who would have thought that?..lol
              historically i've had to redo the driver install as it somehow auto updates itself. i never did a revert (never thought to do that)...just do the same driver install process.


              '06 Carbon Black
              Sabelt, Brey Krause, SuperSprint, AFE, Epic Tune, Volk

              Comment


                #8
                I know that but I don't want a cheap ass cable that will get stuck or have a short life or any other issues.

                The bmw one was discontinued I believe some time ago and am looking for a suitable replacement.
                2003.5 MT JB/B - CSL SCHRICK SUPERSPRINT EISENMANN JRZ SWIFT MILLWAY BREMBO ENDLESS BBS/SSR DREXLER SACHS RECARO SLON MKRS GSP DMG KARBONIUS CP AUTOSOLUTIONS KOYO

                Comment


                  #9
                  These things aren't terribly complex devices. With newer cars (2008+) all of the cables (regardless of price) have a firmware bug that can cause flashes to fail for certain modules. That can be fixed with the ediabaslib firmware. The highest quality cable is probably the one-stop-electronics cable. The bimmergeeks "expert" cable is effectively the one-stop-electronics cable preflashed with the firmware.

                  Or if you can get your hands on it, the Omitec cable is what the BMW engineers used, but that's super expensive, and isn't really compatible with 3rd party tools.

                  Comment


                    #10
                    Looks like my cable is bad. I plugged in another one I have for my E90 (finally found it) and it worked.

                    I bridged the 2 pins on the bad cable. Not sure if that is a contributing factor. It worked for 3-4 years…might just have died on its own.


                    Sent from my iPhone using Tapatalk

                    Comment


                      #11
                      Confirmed...bad cable. Used the other cable. INPA is working great.

                      Comment

                      Working...
                      X